Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
-- Aris Feryanto
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Done.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
OK.
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Done.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
OK.
I finished cleaning code in js/makegrid.js and pushed the changes to my git repo.
I change the structure of the code to match existing PMA code, but I still keep the OOP style inside the function. The new PMA_makegrid() function can accept some optional parameters, in order to adjust which functionality (resize, reorder, show/hide, grid edit) that want to be enabled for a table. This may be useful for applying some features for other types of table (other than the one generated while browsing database).
-- Aris Feryanto
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Done.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
OK.
I finished cleaning code in js/makegrid.js and pushed the changes to my git repo.
I change the structure of the code to match existing PMA code, but I still keep the OOP style inside the function. The new PMA_makegrid() function can accept some optional parameters, in order to adjust which functionality (resize, reorder, show/hide, grid edit) that want to be enabled for a table. This may be useful for applying some features for other types of table (other than the one generated while browsing database).
-- Aris Feryanto
Pushed, thanks.
I am making a last attempt about this issue: do you have an idea about advertising (for example with a tip) about grid editing?
From: Marc Delisle marc@infomarc.info
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info Aris, I would
like to
merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Done.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
OK.
I finished cleaning code in js/makegrid.js and pushed the changes to my git repo.
I change the structure of the code to match existing PMA code, but I still keep the OOP style inside the function. The new PMA_makegrid() function can accept some optional parameters, in order to adjust which functionality (resize, reorder, show/hide, grid edit) that want to be enabled for a table. This may be useful for applying some features for other types of table (other than the one generated while browsing database).
-- Aris Feryanto
Pushed, thanks.
I am making a last attempt about this issue: do you have an idea about advertising (for example with a tip) about grid editing?
Oh, right. Adding tooltips in every editable cells will be disturbing, IMO.
How about add a hint tooltip in "Edit" link in table's rows? Maybe some hint like: "You can also edit a field by clicking directly on a cell in the table.". Actually, we may add more hint to tell the users that grid editing doesn't work for BLOB data type, but the hint will be too long to be displayed.
-- Aris Feryanto
Aris Feryanto a écrit :
From: Marc Delisle marc@infomarc.info
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info Aris, I would
like to
merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Done.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
OK.
I finished cleaning code in js/makegrid.js and pushed the changes to my git repo.
I change the structure of the code to match existing PMA code, but I still keep the OOP style inside the function. The new PMA_makegrid() function can accept some optional parameters, in order to adjust which functionality (resize, reorder, show/hide, grid edit) that want to be enabled for a table. This may be useful for applying some features for other types of table (other than the one generated while browsing database).
-- Aris Feryanto
Pushed, thanks.
I am making a last attempt about this issue: do you have an idea about advertising (for example with a tip) about grid editing?
Oh, right. Adding tooltips in every editable cells will be disturbing, IMO.
How about add a hint tooltip in "Edit" link in table's rows? Maybe some hint like: "You can also edit a field by clicking directly on a cell in the table.". Actually, we may add more hint to tell the users that grid editing doesn't work for BLOB data type, but the hint will be too long to be displayed.
Good idea, but I suggest "You can also edit most columns by clicking directly on their content."
These are columns, not fields; and using "most" explains in a short way that not everything is editable.
On 12 Agu 2011, at 01:01, Marc Delisle marc@infomarc.info wrote:
Aris Feryanto a écrit :
From: Marc Delisle marc@infomarc.info
Aris Feryanto a écrit :
Hi Marc,
From: Marc Delisle marc@infomarc.info Aris Feryanto a écrit :
Hi Marc,
> From: Marc Delisle marc@infomarc.info Aris, I would
like to
> merge this feature but I get merge conflicts, can you have > a look at this? > I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Done.
Btw, I'm currently refactoring and cleaning code in js/makegrid.js and there will be a significant code structure changes in that file. I'll update you once it is finished.
OK.
I finished cleaning code in js/makegrid.js and pushed the changes to my git repo.
I change the structure of the code to match existing PMA code, but I still keep the OOP style inside the function. The new PMA_makegrid() function can accept some optional parameters, in order to adjust which functionality (resize, reorder, show/hide, grid edit) that want to be enabled for a table. This may be useful for applying some features for other types of table (other than the one generated while browsing database).
-- Aris Feryanto
Pushed, thanks.
I am making a last attempt about this issue: do you have an idea about advertising (for example with a tip) about grid editing?
Oh, right. Adding tooltips in every editable cells will be disturbing, IMO.
How about add a hint tooltip in "Edit" link in table's rows? Maybe some hint like: "You can also edit a field by clicking directly on a cell in the table.". Actually, we may add more hint to tell the users that grid editing doesn't work for BLOB data type, but the hint will be too long to be displayed.
Good idea, but I suggest "You can also edit most columns by clicking directly on their content."
These are columns, not fields; and using "most" explains in a short way that not everything is editable.
Great! I think that will work. I'll add this soon.
-- Aris Feryanto
Hi
Dne Wed, 10 Aug 2011 06:35:29 -0700 (PDT) Aris Feryanto aris_feryanto@yahoo.com napsal(a):
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Aris, what is reason for having nearly identical code for grid editing in both sql.php and tbl_replace.php?
Hi Michal,
From: Michal Čihař michal@cihar.com
Hi
Dne Wed, 10 Aug 2011 06:35:29 -0700 (PDT) Aris Feryanto aris_feryanto@yahoo.com napsal(a):
Hi Marc,
From: Marc Delisle marc@infomarc.info
Aris, I would like to merge this feature but I get merge conflicts, can you have a look at this?
I just fixed the merge conflict in my master branch. Kindly merge the grid
editing from there. The master branch also contain some fix for recent tables and configuration for qTip hint. Thanks.
Aris, what is reason for having nearly identical code for grid editing in both sql.php and tbl_replace.php?
Oh, right. I missed this part when removing the inline edit feature. At first, I kept both code because inline edit still need that code in sql.php. Now, I've removed the duplicate code (pushed to my git) from sql.php, leaving it only in tbl_replace.php.
Thank you for noticing this. :)
-- Aris Feryanto
Hi
Dne Wed, 10 Aug 2011 07:57:27 -0700 (PDT) Aris Feryanto aris_feryanto@yahoo.com napsal(a):
Oh, right. I missed this part when removing the inline edit feature. At first, I kept both code because inline edit still need that code in sql.php. Now, I've removed the duplicate code (pushed to my git) from sql.php, leaving it only in tbl_replace.php.
Thank you for noticing this. :)
Well I did not notice it myself I just look at integration server:
https://ci.phpmyadmin.net/job/phpMyAdmin-continuous/216/
Michal Čihař a écrit :
Hi
Dne Wed, 10 Aug 2011 07:57:27 -0700 (PDT) Aris Feryanto aris_feryanto@yahoo.com napsal(a):
Oh, right. I missed this part when removing the inline edit feature. At first, I kept both code because inline edit still need that code in sql.php. Now, I've removed the duplicate code (pushed to my git) from sql.php, leaving it only in tbl_replace.php.
Thank you for noticing this. :)
Well I did not notice it myself I just look at integration server:
Interesting report!