[Phpmyadmin-devel] bookmark bug

Armel FAUVEAU webmaster at phpindex.com
Sun Jul 8 05:22:14 CEST 2001

Oops, i repost this too,

> On Sat, Jul 07, 2001 at 02:11:10PM +0200, Loïc wrote:
> > OK, added to the list. BTW I've tried to merge an uggly workaround
> > for Opera and Konqueror into the code. Could you please give it a try
> Btw, there is again a demo online, but just for "private" use
> (so devel-members) : http://phpmyadmin.sourceforge.net/phpMyAdmin-devel/ .
> It's running using another project I own on sourceforge.
> Just tried to setup bookmark support, but it doesn't seem to
> work (db and table created). To change the setup, you can normaly
> edit the files under /home/groups/p/ph/phpmyadmin/htdocs/phpMyAdmin-devel
> (chowned g+rwx *). Just ssh to shell1.sourceforge.net.

It's ok now.

The problem was in sql.php3 at line 149 :
if($cfgBookmark['db'] && $cfgBookmark['table'] && $db!=$cfgBookmark['db'] &&
This condition is not true, because $db==$cfgBookmark['db'] (odsn)
So no bookmark support :p

I replaced this line by

if($cfgBookmark['db'] && $cfgBookmark['table'] && empty($id_bookmark))

And it's ok now.

But the question is...why i had set this condition under $db and
And at 01:30am, in this rainy night, i don't know :p


More information about the Developers mailing list