[Phpmyadmin-devel] Problem with "Advisor" unit tests

Rouslan Placella rouslan at placella.com
Wed Aug 17 12:26:54 CEST 2011

On Tue, 2011-08-16 at 17:33 +0300, Tyron Madlener wrote:
> On Tue, Aug 16, 2011 at 4:59 PM, Rouslan Placella <rouslan at placella.com> wrote:
> > Hi there,
> >
> > On my computer there is a problem with the unit tests for "Advisor". If
> > I just run the advisor test, everything is fine, it's run very quickly
> > and succeeds. But if I run all unit tests in one go, then the "Advisor"
> > unit test takes over a minute and eats up well over 1GB of my memory
> > (which is unacceptable). However I can't see this issue on
> > ci.phpmyadmin.net, where all tests complete within 25s and using only
> > 85MB of memory. Can anyone else confirm this behaviour? Any ideas what
> > could be the cause of this problem?
> >
> I had a look at the code and test, but I don't see anything
> suspicious. How about running a debugger and observing the code step
> by step?

Well, I don't know how to step through the code especially not in
php-cli. But I ran xdebug on the unit tests and fed it's output to
webgrind, still I can't find anything that stands out as a problem. I've
attached the output of webgrind, in case someone else can find something
interesting in it.

> > I've attached 2 screenshots as proof, one at the beginning of the tests
> > and one just before the Advisor test has finished running.
> >

-------------- next part --------------
A non-text attachment was scrubbed...
Name: webgrind.tar.gz
Type: application/x-compressed-tar
Size: 52867 bytes
Desc: not available
URL: <http://lists.phpmyadmin.net/pipermail/developers/attachments/20110817/5262d96f/attachment.bin>

More information about the Developers mailing list