[Phpmyadmin-devel] problem with the new index editor

Marc Delisle marc at infomarc.info
Mon Dec 19 21:48:06 CET 2011

Marc Delisle a écrit :
> Rouslan Placella a écrit :
>> On 19/12/11 20:29, Marc Delisle wrote:
>>> Rouslan Placella a écrit :
>>>> On 19/12/11 08:37, Piotr Przybylski wrote:
>>>>> 2011/12/19 Rouslan Placella<rouslan at placella.com>:
>>>>>> On 18/12/11 22:35, Piotr Przybylski wrote:
>>>>>>> 2011/12/18 Rouslan Placella<rouslan at placella.com>:
>>>>>>>> On 18/12/11 13:52, Marc Delisle wrote:
>>>>>>>>> Hi,
>>>>>>>>> Try this on sakila.actor:
>>>>>>>>> 1. edit the PRIMARY index and add first_name to it
>>>>>>>>> 2. edit it again and remove first_name
>>>>>>>>> 3. edit it again: first_name is shown as being part of the index
>>>>>>>> Cached pages are being served. I noticed that as well, and the issue
>>>>>>>> seems to be quite old. I'm guessing that PMA_ajaxResponce, which sends a
>>>>>>>> no-cache header, is not being used to handle these requests.
>>>>>>> How about solving caching issue globally with jQuery.ajaxSetup() [1]:
>>>>>>> $.ajaxSetup({cache: false});
>>>>>>> Cacheing issues pop up once in a while, this should solve them once
>>>>>>> and for all.
>>>>>>> [1] http://api.jquery.com/jQuery.ajaxSetup/
>>>>>> Last time I tried, this didn't work for me. Not sure why, but the random
>>>>>> variable that jQuery is supposed to append to the HTTP request was not
>>>>>> coming up...
>>>>> Ok, it seems it's not added for GET and HEAD requests... maybe we
>>>>> could use jQuery.ajaxPrefilter to do add it to our urls. At least it
>>>>> will still be a global solution.
>>>> OK, ajaxPrefilter it is then. I've added it for all AJAX requests, not
>>>> just GET, since we were using ajaxSetup({cache:false}) in a few places
>>>> for POST requests anyway. So this issue and anything else related to
>>>> cached ajax requests should be solved now.
>>>> Commit 0d7b3a5877dc71a0e43759a4bbba6f24ab1f0292
>>> Hmmm, Firebug now shows thousands of errors, is it the same for you?
>> No, I get no firebug errors. What are they? Are they gone if you go back 
>> a few revisions in git?
> I still need to find how they started. I was trying my sakila.actor test 
> case.

I get
$(this).data("qtip") is undefined

Not yet sure how to reproduce this.

Marc Delisle

More information about the Developers mailing list