[Phpmyadmin-devel] Renaming proxy credentials variables
dieter.adriaenssens at gmail.com
Fri Jul 5 17:20:22 CEST 2013
2013/7/5 Mohamed Ashraf <mohamed.ashraf.213 at gmail.com>:
> On Friday, July 5, 2013 at 11:44 AM, Dieter Adriaenssens wrote:
> 2013/6/29 Mohamed Ashraf <mohamed.ashraf.213 at gmail.com>:
> Currently all variables that store proxy credentials have the prefix
> 'VersionCheck' assuming because this was the only part of phpmyadmin
> that uses these variables. However I also require those variables in
> my error reporting code and I did not want to use the same variable
> names since it is a misnomer at that point.
> I renamed the variables and removed all the VersionCheck prefixes so
> they became ProxyUrl, ProxyUser and ProxyPass. I made the changes in
> the version_check.php code and in the docs.
> I just wanted to inform you of this change since this may affect
> others once the error reporting system is merged with master
> Thanks for the update. Did you mention the rename of the parameters in
> ChangeLog as well?
> No I have not. It has not been merged into master so I have no way of
> knowing in which version will this change. Be released
It will be most likely be released in 4.1.0, you can add it there.
If this would change, it can still be moved to a different version in
the ChangeLog, but at least it is there and can't be forgotten.
More information about the Developers