[Phpmyadmin-devel] How hard is the requirement for MySQL >= 5.5 in phpMyAdmin?

Marc Delisle marc at infomarc.info
Wed Aug 13 18:54:30 CEST 2014

Robert Scheck a écrit :
> Hello phpMyAdmin developers,
> how hard is the requirement for MySQL >= 5.5 in phpMyAdmin? Actually, I am
> the package maintainer of phpMyAdmin in Fedora and EPEL. EPEL is an add-on
> repository for Red Hat Enterprise Linux and CentOS (and other derivates).
> However, Red Hat Enterprise Linux 6 is shipping only MySQL 5.1 and Red Hat
> Enterprise Linux 5 is only shipping MySQL 5.0. And unfortunately since the
> phpMyAdmin 4.2.3 release you are enforcing MySQL >= 5.5 as requirement -
> which breaks both of them.
> We could stay with phpMyAdmin 4.0.x for both, but 4.0.x goes EOL already in
> less than 6 months - quite early given that RHEL 6 is supported till 2020
> (and RHEL 5 until end of March 2017). I do not expect that you support old
> releases same long like that. However it would be really helpful can give
> some details why the requirement is enforced and what could break with an
> older version (some specific features, mostly everything, everything?) of
> MySQL.
> Thank you very much for your time already and hope to hear some details :)
> Greetings,
>   Robert

Hi Robert,
today we have extended security support of phpMyAdmin 4.0; the new date 
is Jan 1, 2017.

Marc Delisle (phpMyAdmin)

More information about the Developers mailing list