[phpMyAdmin Developers] require a specific PHP minor version?
michal at cihar.com
Mon Sep 7 14:38:04 CEST 2015
Dne Mon, 07 Sep 2015 08:10:41 -0400
Marc Delisle <marc at infomarc.info> napsal(a):
> Le 2015-09-07 03:40, Michal Čihař a écrit :
> > Hi
> > Dne Sun, 06 Sep 2015 08:27:19 -0400 Marc Delisle <marc at infomarc.info>
> > napsal(a):
> >> Due to  should we * require a minimum PHP version of 5.3.27 in
> >> libraries/common.inc.php for phpMyAdmin 4.4.15?
> >> * mention this requirement in our doc?
> >> * mention it on the downloads page?
> > Looking at the comments, it might be actually fixed already in
> > 5.3.7. Also it can quite easily happen that Redhat will backport the
> > fix to their version, so the strict version check doesn't seem like a
> > good solution.
> We could try to find out the exact PHP version. My point is that we
> should not just require a minimum version of PHP 5.3, as this is not
> true. It affects not just Redhat users but all users having PHP between
> 5.3.0 and, say, 5.3.7.
But looking at version string is still bad idea here - if Redhat will
fix this, their version will be still called 5.3.3, it will just have
applied patch which fixes this particular issue.
> > What I don't understand is what makes
> > mb_strlen($this->_cookie_iv,'8bit') different from
> > strlen($this->_cookie_iv) in this case.
> The stackoverflow question reports three warnings, and the mb_strlen()
> fix was only for one of the warnings. I am not sure either why the fix
> works (looks like some unexpected characters were in the cookie-stored IV.
This would be then incompatibility which could bite users on other
systems as well, though nothing really problematic...
Michal Čihař | http://cihar.com | http://blog.cihar.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 819 bytes
Desc: OpenPGP digital signature
More information about the Developers