[phpMyAdmin Developers] require a specific PHP minor version?
marc at infomarc.info
Mon Sep 7 14:10:41 CEST 2015
Le 2015-09-07 03:40, Michal Čihař a écrit :
> Dne Sun, 06 Sep 2015 08:27:19 -0400 Marc Delisle <marc at infomarc.info>
>> Due to  should we * require a minimum PHP version of 5.3.27 in
>> libraries/common.inc.php for phpMyAdmin 4.4.15?
>> * mention this requirement in our doc?
>> * mention it on the downloads page?
> Looking at the comments, it might be actually fixed already in
> 5.3.7. Also it can quite easily happen that Redhat will backport the
> fix to their version, so the strict version check doesn't seem like a
> good solution.
We could try to find out the exact PHP version. My point is that we
should not just require a minimum version of PHP 5.3, as this is not
true. It affects not just Redhat users but all users having PHP between
5.3.0 and, say, 5.3.7.
>> The alternative I see, is to remove in time for phpMyAdmin 4.4.15
>> the phpseclib fix we did for PHP 7 compatibility in phpMyAdmin
>> 4.4.14. However I would prefer to keep this fix in place, because
>> users of PHP 7 would have to upgrade sooner to phpMyAdmin 4.5,
>> which requires PHP 5.5 to 7.0.
> What I don't understand is what makes
> mb_strlen($this->_cookie_iv,'8bit') different from
> strlen($this->_cookie_iv) in this case.
The stackoverflow question reports three warnings, and the mb_strlen()
fix was only for one of the warnings. I am not sure either why the fix
works (looks like some unexpected characters were in the cookie-stored IV.
The PHP version issue is the explanation for the two other warnings.
> _______________________________________________ Developers mailing
> list Developers at phpmyadmin.net
Marc Delisle | phpMyAdmin
More information about the Developers