[Phpmyadmin-devel] Access denied for user: 'wwwrun at localhost' in /home/admin/www/mysql/lib.inc.php3 on line 6

Olivier M. qmail at orion.8304.ch
Sun Jun 3 11:09:41 CEST 2001

On Sat, Jun 02, 2001 at 07:42:46PM -0400, Marc Delisle wrote:
> > Currently trying the latest "stable" tree, and since
> > the "mysql_db_query deprecate" (lem9,
> > http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/phpmyadmin/phpMyAdmin/lib.inc.php3.diff?r1=1.17&r2=1.18
> > ), I get this error... (php4.0.5, using adv_auth and std_auth
> > Warning: MySQL Connection Failed: Access denied for user: 'wwwrun at localhost' (Using password: NO) in
> > /home/admin/www/mysql/lib.inc.php3 on line 6
> > Warning: MySQL: A link to the server could not be established in /home/admin/www/mysql/lib.inc.php3 on line 6
> >
> > In the setup, the user is "mysql", not "wwwrun" (that is the webserver id).
> > Isn't this a bug ? :)
> Hmmm, if I get the latest stable cvs and run it here, with Apache 1.3.20, PHP 4.0.5
> and MySQL 3.23.38, I have no problem.

Just tried on another server (running "official" mysql+php+apache, installed via RPM), and I
get exactely the same ugly warnings as on my server with "hand-made" php, mysql and apache.

I have to comment these lines in lib.inc.php3 to make it disapear:
//if (isset($db)) {
//  mysql_select_db($db); 

> However, I had weird MySQL problems and solved them by compiling MySQL with gcc 2.95.3, not egcs.  A lot of people on the mysql
> list have those problems: the show databases and show tables don't work, if compiled with the wrong compiler.

the tables and db are showed, no problem about that here...

> > GRANT Select, Insert, Update, Delete, Create, Drop, Reload, Shutdown, Process, File, References, Index, Alter ON cyphor.* TO
> > 'olivier'@'%' with grant option
> > MySQL a répondu: Can't find any matching row in the user table
> Do you really have this combination of user olivier and hostname % in your user table?

yes I do.

> > so the fields name are not corresponding...  Maybe a mysql-version compatiiblity
> > problem ? (MySQL 3.23.30-gamma)
> The grant syntax does not use the internal field names of the user table, so I don't see a problem here.

ah ok, I never used GRANT yet (doing this by hand in the mysql-db directely).

Well, this warning-problem is quite strange, especially if I'm the
only one seeing them :) 

 Olivier Mueller - om at 8304.ch - PGPkeyID: 0E84D2EA - Switzerland
qmail projects: http://omail.omnis.ch  -  http://webmail.omnis.ch

More information about the Developers mailing list