[phpMyAdmin Developers] require a specific PHP minor version?

Michal Čihař michal at cihar.com
Mon Sep 7 09:40:37 CEST 2015


Dne Sun, 06 Sep 2015 08:27:19 -0400
Marc Delisle <marc at infomarc.info> napsal(a):

> Due to [0] should we
> * require a minimum PHP version of 5.3.27 in libraries/common.inc.php
> for phpMyAdmin 4.4.15?
> * mention this requirement in our doc?
> * mention it on the downloads page?

Looking at the comments, it might be actually fixed already in 5.3.7.
Also it can quite easily happen that Redhat will backport the fix to
their version, so the strict version check doesn't seem like a good

> The alternative I see, is to remove in time for phpMyAdmin 4.4.15 the
> phpseclib fix we did for PHP 7 compatibility in phpMyAdmin 4.4.14.
> However I would prefer to keep this fix in place, because users of PHP 7
> would have to upgrade sooner to phpMyAdmin 4.5, which requires PHP 5.5
> to 7.0.

What I don't understand is what makes
mb_strlen($this->_cookie_iv,'8bit') different from
strlen($this->_cookie_iv) in this case.

> [0]
> http://stackoverflow.com/questions/32349895/warning-in-libraries-phpseclib-crypt-base-php967

	Michal Čihař | http://cihar.com | http://blog.cihar.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.phpmyadmin.net/pipermail/developers/attachments/20150907/e843e37f/attachment.sig>

More information about the Developers mailing list