On Mon, 22 Jul 2002, Div Lo�c wrote:
Some coding standard fixes also :
- function names should not contain escaped charcters except after the "PMA" prefix ie "PMA_number_inrange()" should be "PMA_numberInRange".
I have a request to make of the list. In the interests of keeping the code seperate, and having managable functin names, are sub-prefixes permissiable to better indicate the seperation of code ?
Eg for my Parser The prefix could be either PMAsqp_ or PMA_SQP_
(I'd go for the second one, as it is still compliant with the PEAR naming conventions http://pear.php.net/manual/en/standards.naming.php)
As things stand, I have been using PMA_sqlParser_* for functions specific to the parser PMA_str_* for functions dealing with strings and PMA_* for functions not directly specific to the parser (the character type matching for example).
I've modified your "sqlparse.php3" file in order it fits PEAR coding standards (excpet comments for function) and may run with PHP3. But I can't test it before the end of the week. You'll find it attached to this message. From seeing your work, I've made most of the changes in my own codebase
with the suggestions from the list.